ForumSite Announcements ► Two Cans App bug thread
Sign up for the mobile app beta! The link is at the top of the page.

Please reply to this thread with bugs. I'll update this first post with the current bug list.

Top UI
  • AA buttons are kind of ugly
  • BB No currently-logged-in profile tile
  • Night mode/Theme switching buttons are hard to push
  • No notifications about new answers and new messages

Feed tab:
  • AA It's ugly
  • AA The buttons do nothing.
  • BB All the buttons go to the right place now.
  • Scrolling does not load more feed items

Answer questions
  • AA Top button navigation not implemented. Currently just says "top buttons".
  • AA No way to access saved questions
  • BB Newlines are ignored.
  • No visual feedback on what swiping does
  • Box to type answers doesn't comply with themes/night mode
  • Polls are not displayed
  • No visual cue to tap the card when it overflows
  • Occasionally the border around the card doesn't appear unless you switch to a different theme and then switch back.
  • Implement flagging
  • Sending a question while a card is expanded puts the card UI in a weird state for the next question.
  • No user attribution is displayed for public questions.

Your questions
  • AA The question list is TOO minimalistic
  • AA no indication of where new answers are
  • AA No way to ask a new question
  • BB No indication of what is active
  • BB Cannot add a poll to a question
  • BB Cannot mark a question as public.
  • BB No way to delete your questions.
  • BB No way to pin/unpin questions.
  • BB Cannot see time/date of question.

Answers to your questions
  • AA Whole UI is ugly
  • AA UI does not comply with night mode
  • BB Newlines are ignored.
  • BB No way to delete answer
  • BB No way to start chat conversation
  • No way to mark as read
  • "view message" for answers on the ask page does nothing.

Forum
  • BB No information shown about threads on category page.
  • BB Cannot view threads
  • CC Text in new post notification wraps weirdly.
  • Cannot scroll through threads
  • Cannot reply to threads
  • Locked and sticky threads have no indication
  • User info not visible in thread list.
  • Themes do not play well with forum posts.
  • "New posts" button doesn't seem to show new posts in the thread so much as all new posts regardless of relevence.

Chat
  • Emoji picker goes off the top edge of the screen.
  • Labels for the options section in messaging threads render black regardless of theme, making them illegible in dark mode.
  • same issues as before since it's the same code. Will merge those problems into this thread.

Settings
  • Lol, it does nothing.

Login page
  • Does not comply with night mode

Profiles
  • Viewing
  • Editing

Misc
  • BB If you log out and log back in, old pages are cached and show data from the previous account
  • Scrolling by tapping, dragging, and releasing your finger in less than 100 milliseconds is treated like a regular tap.
  • Hard app crash when internet connection isn't available.
  • Changing phone orientation destroys the universe
  
Answer questions: Questions' contents are truncated if they're too long for the question card. (But I can long press and drag the selection handles to trick the text into scrolling.)
Nevermind I hadn't tried just tapping once.
  
I'll be adding better indications of what different motions do.
  
A new version is up! This one is called angsty-apricot.

The one after that will be belligerent-banana. You can guess where I'm going with this.

Versions will automatically expire when the next version is available and you'll be alerted to download the next one (this is a beta, after all).

When I cross out bugs, I'll note which version the fix is available in with initials (e.g. BB means belligerent-banana has the fix).
  
On the chat's emoji section, you can't switch between categories
  
Scrolling fast past the bottom of the 'saved questions' page boots you back to the main answer screen.
  
Small issue. The animation for swiping a question to skip is pretty choppy
  
Should I have received a notice to download angry apricot? If so, I did not.
  
Blake said:
Versions will automatically expire when the next version is available and you'll be alerted to download the next one (this is a beta, after all).
  
While viewing questions (both ones you asked and in the Q&A), intentional newlines are ignored.
  
Wyyca21 said:
Blake said:
Versions will automatically expire when the next version is available and you'll be alerted to download the next one (this is a beta, after all).


Right, this is why I asked? Blake's post made it sound like Angry Apricot was already out. I wanted to double check that there's not an issue with whatever alert I should be receiving.
  
I think if there was a problem, you would be unable to use the Beta.
Because it'll expire after the new one is up.
I'd recommend keeping an eye on the App Beta Test thingy. Like, click on it every once in a while.
  
eriophora said:
Wyyca21 said:
Blake said:
Versions will automatically expire when the next version is available and you'll be alerted to download the next one (this is a beta, after all).


Right, this is why I asked? Blake's post made it sound like Angry Apricot was already out. I wanted to double check that there's not an issue with whatever alert I should be receiving.
You're different! Because you were the first person to download it a couple days ago and the self-destruct feature wasn't implemented in that.
  
On the chat's emoji section, you can't switch between categories

Adding this as "Emoji picker goes off the top edge of the screen"

Coldfrost said:
Scrolling fast past the bottom of the 'saved questions' page boots you back to the main answer screen.

Adding this as "Scrolling by tapping, dragging, and releasing your finger in less than 100 milliseconds is treated like a regular tap." which is a systemic issue I've been meaning to fix and have subconsciously adjusted my own behavior to avoid this and now I'm realizing I forgot about it. It's not that it's going back, it's just queueing the next question that you happened to release your finger on.

Small issue. The animation for swiping a question to skip is pretty choppy
Initially the first time you try to swipe or always? Is this specific for skipping or applicable to saving too? Is this while you're moving the card or when you release it?

Kylljoy said:
While viewing questions (both ones you asked and in the Q&A), intentional newlines are ignored.

Added as "newlines are ignored" under several sections.
  
Swiping issue seems to be magically fixed. Might've been my phone being jank
  
Somehow I didn't even realize it was taking me to a question I'd saved.

Answering a question while it is expanded will open the next question already expanded. Collapsing that question will leave the formatting all janky- the box will fit to the amount of text instead of being square, will be right-aligned instead of centered, will push parts of the question off-screen if there's a really long word, and the swiping animations will not work. Re-expanding and collapsing does not fix.
  
Is there intended to be a flagging/reporting mechanism in the app for the Q&A?
  
Kylljoy said:
Is there intended to be a flagging/reporting mechanism in the app for the Q&A?

Yes!

Basically, I intend for the app to be the primary means that people will be using for TwoCans, so everything will be doable in the app.

Eventually, the app UI will be tweaked to also be "desktop-friendly" in much the way that I failed to tweak the desktop UI to be "mobile-friendly" and it will replace the existing desktop web experience.
  
The app crashes if it loads without an internet connection. No error messages, it just crashes without an explanation.
  
If I delete a saved question in-browser, then try to open it in-app without refreshing the page, it displays just the text, no box, no way to answer. The question number is at the top of the page.

Also I found a question on the app, answered it in-browser, then tried to answer it in the app. I'm not sure if it went through (I told them to message me back), but the app wouldn't load more questions (I tried tabbing back and forth a few times) until I closed the app and re-started it. Loading up a saved question and skipping it did pull up another new question, too.
I tried doing it in reverse, answering in-app then in-browser. The browser just threw up an undefined error message.
  
New questions made from the app do not appear in the overall list of questions on the app - although they do appear on desktop. EDIT: they apparently appear eventually - just not in real time.

If you flick to scroll on the forums as opposed to slowly sliding with your finger, it rapidly scrolls to the bottom BUT then it opens whichever category your finger started on when you flicked it rather than just staying at the bottom of the forum category list.

Users who are on the forum from the app do not register in the "on the forum now" list.
  
If you rotate your phone to landscape, the question boxes are super tiny and not very useful.
  
Belligerent Banana is now released!

Changelog:
  • General - Added profile tile to the top right
  • General - If you log out and log back in, old pages are cached and show data from the previous account
  • General - Theme toggle is moved to the main drop-down menu
  • Feed - Clicking on feed items takes you to the right place for the most part
  • Ask - Newlines are ignored in answers
  • Ask - No indication of what is active
  • Ask - Cannot add a poll to a question
  • Ask - Cannot mark a question as public.
  • Ask - No way to delete your questions.
  • Ask - No way to pin/unpin questions.
  • Ask - Cannot see time/date of question
  • Ask - No way to delete answers
  • Ask - No way to start chat conversation
  • Forum - No information shown about threads on category page
  • Forum - Cannot view threads (although scrolling is currently messed up)
  
Oookay, here's what I've somehow managed to break in the first twenty minutes

  • Changing orientation of the phone kicks the user back to the ask page, regardless of the page they were on
  • Is the PFP in the top right being broken a known bug or not? Because I'm seeing a "broken image" photo
  • Quote box profile links in Dark Mode have low contrast and are somewhat hard to read (not sure how fixable this is)
  • UI is a bit buggy with text wrapping on forum main page causing "new posts" text to partially render over other text
  • Labels for the options section in messaging threads render black regardless of theme, making them illegible in dark mode.
  • "New posts" button doesn't seem to show new posts in the thread so much as all new posts regardless of relevence.
  • Haven't seen it in the bug list, but "view message" for answers on the ask page does nothing.

<PENDING MORE BUGS...>
  
  • Profile and settings buttons don't actually do anything? I don't know if this is intentional or not.
  • Answering expanded questions still does weird things. In addition to the formatting strangeness, the swiping is much more touchy. Can slide just millimeters to one side, even retuning to the center, and it'll still go to the pile. Also if there question is short enough there's a weird gray bar under it?
  
Forum > Site Announcements > Two Cans App bug thread